Quadrant v3: All 3 axis unstable (flickering, vibrating)

  • Name of Control (Download Title)
    Spitfire MkIX Add On Kit B
    Version Number


    I am not an AuthentiKit beginner and have already completed several builds. Recently, I wanted to build version 3 from scratch to replace my faulty Throttle Quadrant v1. The old Throttle Quadrant had problems with the Prop RPM axis, which was known to be a bit fragile. Recently, none of the axles worked properly and I think that this is important for the general problem solution: When I pushed the throttle forward in the game, the input was given, but as soon as I let go of the throttle (i.e. no more active input), the throttle was reduced again.

    Current problem:

    After assembly, I connected the quadrant and calibrated it in vJoy. However, I immediately noticed that all 3 axis are unstable and, according to the raw data, jump back and forth +5/-5% several times per second. In the game, I could hardly fix the axis and the same problem occurred as described earlier for the old Quadrant. Here, too, the throttle was pulled back and the throttle was somehow synced with the RMP lever, although these were clearly separate axis in the key mapping.

    What works:

    In vJoy, the axis all work normally, so I can move them along their entire length and this is also displayed correctly after calibration. The bomb release button also works.

    Previous attempts to solve the problem:

    Obviously, it seems that something is wrong with the HUB. However, I have tried to eliminate all known problems:


    1. all earth cables in the hub renewed incl. cables reconnected -> the axles became somewhat more stable and the deflection was no longer as strong (+/-1%).

    2. all red cables in the hub replaced incl. cables reconnected

    3. replace throttle RJ45 connector in the hub and reconnect all cables and check for shorts.

    4. unplugged the other builds (Gear Lever, Trim Wheels and Spade) and tested as follows

    5. shook and moved the cables in the hub, but there was no change

    Connection cable:

    6. replaced RJ-45 cable, tested several

    Throttle quadrant:

    7. replaced RJ45 connector and reconnected all cables.

    8. red & black cable replaced and reconnected to the other cables

    9. only one black cable connected at a time (to exclude interference, e.g. from the bomb release).

    10. disconnect all cables except black/red individually from the RJ45 connector to identify a possible fault

    11. connection of the red and black cables crimped, not just twisted.

    Further possibilities could be:

    - A bad connection between a cable and one of the Hall sensors (would this then affect all axis?)

    - A fine conductor break on one of the cables of a Hall sensor (probably red or black).

    - The pins for the throttle of the BU board is defective (possibly due to a previous short circuit)

    Thanks for any help! I hope we can narrow it down!

  • I narrowed it down a bit.

    Seems to be the magnetic field generated by the two front motors of the motion rig. If the rj45 cable is close to them (like 40cm) it generates some noise to the hall sensor data. It's not a deal breaker, it's just enough to see the throttle vibrating in-game. I'm no an electrician but it should be possible to ground the cable or something like that.

    Thanks anyway Phil! Disassembly would have been in vain.

  • Solution:
    1. Renew the grounding cables in the hub and crimped the cables together instead of just twisting them (reduced flickering from +/-5% to +/-1% in my case).

    2. The remaining noise in the signal seems to be caused by the magnetic field of the motion rig motors affecting the RJ45 cable. The quadrant is working, but in game you can see the throttle "vibrating" because of that. I replaced the RJ45 cable CAT. 6 with a CAT. 7 cable, which is much better shielded. The noise level is now at +/-0.1% which is perfectly fine.

    Problem solved.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!