Grip Twist Not Working

  • I recently completed my P-51 throttle and everything is working except my twist grip. I have the 'Z Rotation' displayed in the game controllers properties, but it is unresponsive. I have unassembled once to check the connections and ended up reassembling the MagHall to make sure connections were solid, only to reassemble with the same issue.

    I've attached pictures of my hub (note that I used brown instead of green wire..it's what i had), and my throttle RJ45 connector. Welcome any troubleshooting suggestions, otherwise my plan is to disassemble and wire up just the twist grip in an unassembled state to test the MagHall. Appreciate any help.

    • New
    • Official Post

    Ok, good news is that you have all axes recognised. There is a bar for each one, even if not moving.


    I see you didn’t strip the wires in the RJ sockets. I’ve known the punch down/through method fail, in that the wire inside the insulation doesnt make contact. For peace of mind i’d suggest stripping the wires (carefully as per my video) and reseating them. Then we can rule out that possibility.


    Finally, we can do a test to work out if the issue is the throttle or the hub. Please show a larger pic of the hub first so i can see all the wires.


    Actually, one more thing, when in game controllers, hit Settings, Calibrate, Show Raw Data, and tell me the range of nunbers shown when you twist the grip.

  • I stripped and reseated the wires on both RJ45 connectors (throttle and hub) with no change. In the calibration process, the Z rotation access shows a raw value of '0' through the entire rotation of the twist grip. I've attached complete picture of the hub, trying to push the other wires out of the way, but can disconnect everything but the H8 port if need be. I appreciate the help.

  • Well that's certainly embarrassing. It was staring me in the face. Thank you for the fresh set of eyes!

    Unfortunately after correcting that, I still have the same issue. Given my last error I think I need to go over the diagram and my wiring again to be certain I didn't muck it up elsewhere.

  • I took your suggestion and reworked the twist grip RJ45 wiring to connect to H2 as the mixture MagHall, and that worked well. Fortunately that worked, so I don't need to disassemble the twist grip again as I know it works.

    I then reset the twist grip and rewired H8 with all new wires. I still have the same issue. I did, however, occasionally getting a Windows notification that the USB device is drawing too much power. Thinking this may be an indication of a short, I again re-seated all the RJ45 wiring. Welcome any suggestions on next troubleshooting steps, I'm starting to wonder if my board has problems.

    • New
    • Official Post

    Sorry for the delay. I’ve been on the road a lot recently and currently on a ferry to France. I find the boards very robust and have never damaged one. Try disconnecting the H2 wires from the BU and just getting H8 working. Some people have found stray strands of wire shorting RJ45 channels so give them a good shake out.

  • No worries. I hadn't had much time to work on this. I did remove all other wires from the board and connected only H8. The Z rotation access pops up in the Windows controller app showing about 50% rotated and then 1-2 seconds later drops to zero. There is still no response to rotation when connected to H8.

    I wired and rewired H8 several times now and changed the RJ45 jack. I'm at a real loss. I moved on to the pedestal, unfortunately that one is giving me problems as well. Apparently the P-51 and I don't get along...the Spit and P-40 controls were a breeze! :)

    • New
    • Official Post

    Hi,

    Sorry i’m on holiday at the moment so not much time to apply to this. Please start a second thread for the pedestal though as that is quite simple wiring and should be easier to resolve. As for the Z rotation that input looks promising. Can you give me the range of raw data when you turn it? Run the windows games controller, click settings and calibrate and tick raw data. A screenshot of what it shows for max and min would be very useful.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!