P51 Pedestal Issues - trim, aileron, flaps

  • Hello, I have just assembled my P-51 Pedestal, and I attempted to plug it in to my PC, and I have a few issues while looking at the joy.cpl control inputs. When I roll the rudder trim either direction, it shows button presses alternating between 9 and 10. The Elevator only recognizes button 12 for either direction of rotation. Just pulses 12 over and over. The flaps appear to work correctly, however when in the full flaps position, or 0 flap position, the button stays toggled. I chased all the connections, wiring and pin mapping on the USB board. I even tried reseating connections again, but have the same issue happening no matter what I have tried. I want to get this beauty working so I can move on to the throttle next! appreciate any feedback or suggestions.


    Also saw that the video of the pedestal assembly shows he has a working aileron trim, but all the documentation showed it wasn't yet supported. has anyone got it going? How did you do it?

  • Administrator

    Changed the title of the thread from “P51 Pedestal Issues” to “P51 Pedestal Issues - trim, aileron, flaps”.
    • Official Post

    Hi – thanks for posting these questions. I have some answers for you and hopefully they will help others too. The issue with the elevator trim and rudder trim is a general one about configuring your universal hub. Please see this support question as it explains how the hub inputs 9/10 & 11/12 need to be set for encoders. Also for the aileron to work you need to similarly map 5/6.



    Regarding flaps not releasing, this seems to be something that happens to some people and appears to be a consequence of variabilities of the 3D printing so that the end positions don’t quite give enough travel for the lever ON state to revert back to OFF. I’ve already modified the design once to give more travel but i’d better tweak it again. For now i’m afraid you’re best bet is to use some sandpaper to deepen the slot at each end.

  • This is exactly what I was hoping to hear. Something simple. I can hog out a little of the flap opening to allow for more travel too. When this is done I will check again and post the results!


    regards.


    R

    • Official Post

    Thanks, please do! By the way, I'm trying to think of where I can highlight the need to configure the BU board for encoders. Did you watch an assembly video to put the Universal Hub together?


    Actually, just rereading your post the fact 12 pulses constantly seems odd - no 11 pulse? Let's check the encoder is set right first but there maybe a wiring issue as well.


    Was it this one?

    External Content youtu.be
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

  • I am a little embarrassed. I had used the pedestal assembly video, and when I assembled the hub, I started off with this video, but went back to the paper instructions that came with my kit to finish the wiring, and I never finished to see the configuration part of the video! This one was definitely on me. At any rate, I appreciate the dedicated support and the time you take to follow up with questions!

  • Administrator, the tuning app worked for my rudder. I hogged out some of the material in the flaps channel and it now functions properly. my elevator now recognizes 11 and 12 buttons, but it will not behave. it is just pulsing randomly between 11 and 12 either direction of travel. I set the 11-12 to 1:1 and pulse width to 32 ms. am I missing something?


    this is in the encoder config tool. I have the authentikit tuning app as well, but it gives me an error code saying it cannot recognize the Vjoy.

    • Official Post

    I’d strongly suggest leaving out the tuning app for now until you have it working without and then post any separate issues about the tuning app. That’s because some tuning app modes involve disabling encoder mode.


    Anyway, you say you’ve got 11/12 pulsing randomly and you’ve got the board configured for 11/12 as an encoder. Please post a screenshot of your encoder config and one of joy.cpl with both 11 &12 set on which is a state you get when they pulse randomly

  • Try plugging the rudder into the elevator trim input. If it’s the same we narrow the issue down to the BU board config. Might as well try the elevator trim into the rudder input too. Then post some photos of the wiring into the Rj45 on the hub and the wiring connections to the board.

    This did it. The issue moved with the rudder/elevator swap, so I looked into the RJ45 plug on the hub for elevator and the green wire appeared to be connected, but when I removed it, the ends of the wire had been severed. Stripped some insulation off and everything works as it should now.


    What pins on the BU do aileron trims get wired to?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!